summaryrefslogtreecommitdiffstats
path: root/tv/5pkgs/override
diff options
context:
space:
mode:
Diffstat (limited to 'tv/5pkgs/override')
-rw-r--r--tv/5pkgs/override/anbox.nix72
-rw-r--r--tv/5pkgs/override/default.nix4
-rw-r--r--tv/5pkgs/override/fzf/complete1.patch55
-rw-r--r--tv/5pkgs/override/fzf/default.nix9
-rw-r--r--tv/5pkgs/override/gitAndTools.nix5
-rw-r--r--tv/5pkgs/override/input-fonts.nix13
6 files changed, 0 insertions, 158 deletions
diff --git a/tv/5pkgs/override/anbox.nix b/tv/5pkgs/override/anbox.nix
deleted file mode 100644
index 39406173..00000000
--- a/tv/5pkgs/override/anbox.nix
+++ /dev/null
@@ -1,72 +0,0 @@
-self: super:
-
-# https://github.com/NixOS/nixpkgs/pull/125600
-super.anbox.overrideAttrs (old:
- assert old.version == "unstable-2020-11-29";
- rec {
- version = "unstable-2021-05-26";
-
- src = self.fetchFromGitHub {
- owner = old.pname;
- repo = old.pname;
- rev = "ad377ff25354d68b76e2b8da24a404850f8514c6";
- sha256 = "1bj07ixwbkli4ycjh41mnqdbsjz9haiwg2nhf9anbi29z1d0819w";
- fetchSubmodules = true;
- };
-
- postPatch = old.patchPhase;
-
- # patchPhase() from <nixpkgs/pkgs/stdenv/generic/setup.sh>
- # TODO patchPhase = default.patchPhase; or something
- patchPhase = ''
- runHook prePatch
-
- for i in ''${patches:-}; do
- header "applying patch $i" 3
- local uncompress=cat
- case "$i" in
- *.gz)
- uncompress="gzip -d"
- ;;
- *.bz2)
- uncompress="bzip2 -d"
- ;;
- *.xz)
- uncompress="xz -d"
- ;;
- *.lzma)
- uncompress="lzma -d"
- ;;
- esac
- # "2>&1" is a hack to make patch fail if the decompressor fails (nonexistent patch, etc.)
- # shellcheck disable=SC2086
- $uncompress < "$i" 2>&1 | patch ''${patchFlags:--p1}
- done
-
- runHook postPatch
- '';
-
- patches = [
- # Fixes compatibility with lxc 4
- (self.fetchpatch {
- url = "https://git.alpinelinux.org/aports/plain/community/anbox/lxc4.patch?id=64243590a16aee8d4e72061886fc1b15256492c3";
- sha256 = "1da5xyzyjza1g2q9nbxb4p3njj2sf3q71vkpvmmdphia5qnb0gk5";
- })
- # Wait 10× more time when starting
- # Not *strictly* needed, but helps a lot on slower hardware
- (self.fetchpatch {
- url = "https://git.alpinelinux.org/aports/plain/community/anbox/give-more-time-to-start.patch?id=058b56d4b332ef3379551b343bf31e0f2004321a";
- sha256 = "0iiz3c7fgfgl0dvx8sf5hv7a961xqnihwpz6j8r0ib9v8piwxh9a";
- })
- # Ensures generated desktop files work on store path change
- (self.fetchpatch {
- url = "https://raw.githubusercontent.com/NixOS/nixpkgs/fdf7b4be1a659ed8b96586c2fc8ff90850e25feb/pkgs/os-specific/linux/anbox/0001-NixOS-Use-anbox-from-PATH-in-desktop-files.patch";
- sha256 = "173z84g1r8h367a2dgk6945is6vxg4j1hs2hkfd3m3bbpwfw9221";
- })
- # Provide window icons
- (self.fetchpatch {
- url = "https://github.com/samueldr/anbox/commit/2387f4fcffc0e19e52e58fb6f8264fbe87aafe4d.patch";
- sha256 = "12lmr0kxw1n68g3abh1ak5awmpczfh75c26f53jc8qpvdvv1ywha";
- })
- ];
-})
diff --git a/tv/5pkgs/override/default.nix b/tv/5pkgs/override/default.nix
deleted file mode 100644
index f719a9f6..00000000
--- a/tv/5pkgs/override/default.nix
+++ /dev/null
@@ -1,4 +0,0 @@
-with import ../../../lib;
-self: super:
-
-mapNixDir (path: import path self super) ./.
diff --git a/tv/5pkgs/override/fzf/complete1.patch b/tv/5pkgs/override/fzf/complete1.patch
deleted file mode 100644
index 4b2126a2..00000000
--- a/tv/5pkgs/override/fzf/complete1.patch
+++ /dev/null
@@ -1,55 +0,0 @@
-diff --git a/src/core.go b/src/core.go
-index a18c3a1..a3d92a4 100644
---- a/src/core.go
-+++ b/src/core.go
-@@ -331,6 +331,13 @@ func Run(opts *Options, version string, revision string) {
- }
- }
- terminal.UpdateList(val, clearSelection())
-+ if (opts.Complete1) {
-+ count := val.Length()
-+ if count == 1 {
-+ opts.Printer(val.Get(0).item.AsString(opts.Ansi))
-+ terminal.reqBox.Set(reqClose, nil)
-+ }
-+ }
- }
- }
- }
-diff --git a/src/options.go b/src/options.go
-index a55dc34..7f121cd 100644
---- a/src/options.go
-+++ b/src/options.go
-@@ -92,6 +92,7 @@ const usage = `usage: fzf [options]
- -1, --select-1 Automatically select the only match
- -0, --exit-0 Exit immediately when there's no match
- -f, --filter=STR Filter mode. Do not start interactive finder.
-+ --complete-1 Exit interactive finder when there's exactly one match
- --print-query Print query as the first line
- --expect=KEYS Comma-separated list of keys to complete fzf
- --read0 Read input delimited by ASCII NUL characters
-@@ -208,6 +209,7 @@ type Options struct {
- Query string
- Select1 bool
- Exit0 bool
-+ Complete1 bool
- Filter *string
- ToggleSort bool
- Expect map[tui.Event]string
-@@ -269,6 +271,7 @@ func defaultOptions() *Options {
- Query: "",
- Select1: false,
- Exit0: false,
-+ Complete1: false,
- Filter: nil,
- ToggleSort: false,
- Expect: make(map[tui.Event]string),
-@@ -1311,6 +1314,8 @@ func parseOptions(opts *Options, allArgs []string) {
- opts.Exit0 = true
- case "+0", "--no-exit-0":
- opts.Exit0 = false
-+ case "--complete-1":
-+ opts.Complete1 = true
- case "--read0":
- opts.ReadZero = true
- case "--no-read0":
diff --git a/tv/5pkgs/override/fzf/default.nix b/tv/5pkgs/override/fzf/default.nix
deleted file mode 100644
index 661db0ed..00000000
--- a/tv/5pkgs/override/fzf/default.nix
+++ /dev/null
@@ -1,9 +0,0 @@
-self: super:
-
-super.fzf.overrideAttrs (old: {
- # XXX cannot use `patches` because fzf has a custom patchPhase
- patchPhase = ''
- patch -Np1 < ${./complete1.patch}
- ${old.patchPhase or ""}
- '';
-})
diff --git a/tv/5pkgs/override/gitAndTools.nix b/tv/5pkgs/override/gitAndTools.nix
deleted file mode 100644
index a460773b..00000000
--- a/tv/5pkgs/override/gitAndTools.nix
+++ /dev/null
@@ -1,5 +0,0 @@
-self: super:
-
-super.gitAndTools // {
- inherit (self) diff-so-fancy;
-}
diff --git a/tv/5pkgs/override/input-fonts.nix b/tv/5pkgs/override/input-fonts.nix
deleted file mode 100644
index 6ee7afac..00000000
--- a/tv/5pkgs/override/input-fonts.nix
+++ /dev/null
@@ -1,13 +0,0 @@
-self: super:
-
-super.input-fonts.overrideAttrs (old: rec {
- src = self.fetchzip {
- url = "http://xu.r/~tv/mirrors/input-fonts/Input-Font-2.zip";
- sha256 = "1q58x92nm7dk9ylp09pvgj74nxkywvqny3xmfighnsl30dv42fcr";
- stripRoot = false;
- };
- sourceRoot = null;
- outputHash = null;
- outputHashAlgo = null;
- outputHashMode = null;
-})