summaryrefslogtreecommitdiffstats
path: root/tv/3modules/org.freedesktop.machine1.host-shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tv/3modules/org.freedesktop.machine1.host-shell.nix')
-rw-r--r--tv/3modules/org.freedesktop.machine1.host-shell.nix28
1 files changed, 0 insertions, 28 deletions
diff --git a/tv/3modules/org.freedesktop.machine1.host-shell.nix b/tv/3modules/org.freedesktop.machine1.host-shell.nix
deleted file mode 100644
index e1a5323d..00000000
--- a/tv/3modules/org.freedesktop.machine1.host-shell.nix
+++ /dev/null
@@ -1,28 +0,0 @@
-{ config, ... }: let lib = import ../../lib; in {
- options.org.freedesktop.machine1.host-shell.access = lib.mkOption {
- default = {};
- type =
- lib.types.addCheck
- (lib.types.attrsOf (lib.types.attrsOf lib.types.bool))
- (x:
- lib.all
- lib.types.username.check
- (lib.concatLists
- (lib.mapAttrsToList
- (name: value: [name] ++ lib.attrNames value)
- x)));
- };
- config.security.polkit.extraConfig = let
- cfg = config.org.freedesktop.machine1.host-shell;
- enable = cfg.access != {};
- in lib.optionalString enable /* js */ ''
- polkit.addRule(function () {
- var access = ${lib.toJSON cfg.access};
- return function(action, subject) {
- if (action.id === "org.freedesktop.machine1.host-shell"
- && (access[subject.user]||{})[action.lookup("user")])
- return polkit.Result.YES;
- }
- }());
- '';
-}