summaryrefslogtreecommitdiffstats
path: root/tv/3modules/dnsmasq.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tv/3modules/dnsmasq.nix')
-rw-r--r--tv/3modules/dnsmasq.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/tv/3modules/dnsmasq.nix b/tv/3modules/dnsmasq.nix
index ec927f98..ab24ac08 100644
--- a/tv/3modules/dnsmasq.nix
+++ b/tv/3modules/dnsmasq.nix
@@ -31,8 +31,9 @@ in {
};
services.dnsmasq.enable = true;
services.dnsmasq.extraConfig = ''
+ bind-interfaces
dhcp-range=${cfg.dhcp-range}
- interface=${cfg.interface}
+ listen-address=${cfg.address}
'';
tv.iptables.extra.filter.INPUT = [
"-i ${cfg.interface} -p tcp -m tcp --dport bootps -j ACCEPT"