summaryrefslogtreecommitdiffstats
path: root/tv/2configs/xp-332.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tv/2configs/xp-332.nix')
-rw-r--r--tv/2configs/xp-332.nix19
1 files changed, 8 insertions, 11 deletions
diff --git a/tv/2configs/xp-332.nix b/tv/2configs/xp-332.nix
index a66b884c..daabe5b6 100644
--- a/tv/2configs/xp-332.nix
+++ b/tv/2configs/xp-332.nix
@@ -19,17 +19,14 @@ with import <stockholm/lib>;
packageName pkg == "imagescan-plugin-networkscan";
nixpkgs.overlays = singleton (self: super: {
- utsushi-customized = self.utsushi.override {
- guiSupport = false;
- jpegSupport = false;
- networkSupport = true;
- ocrSupport = false;
- saneSupport = true;
- tiffSupport = true;
-
- logCategory = "ALL";
- logLevel = "BRIEF";
- };
+ utsushi-customized = self.utsushi.overrideAttrs (old: {
+ postInstall = ''
+ ${old.postInstall or ""}
+ ln -s /etc/utsushi.conf $out/etc/utsushi/utsushi.conf
+ ln -s ${pkgs.imagescan-plugin-networkscan}/lib/utsushi/networkscan \
+ $out/libexec/utsushi/
+ '';
+ });
});
services = {