summaryrefslogtreecommitdiffstats
path: root/tv/2configs/w110er.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tv/2configs/w110er.nix')
-rw-r--r--tv/2configs/w110er.nix42
1 files changed, 42 insertions, 0 deletions
diff --git a/tv/2configs/w110er.nix b/tv/2configs/w110er.nix
new file mode 100644
index 00000000..e580b216
--- /dev/null
+++ b/tv/2configs/w110er.nix
@@ -0,0 +1,42 @@
+{ pkgs, ... }:
+
+{
+ imports = [
+ ../2configs/smartd.nix
+ ];
+
+ boot.extraModprobeConfig = ''
+ options kvm_intel nested=1
+ '';
+
+ boot.initrd.availableKernelModules = [ "ahci" ];
+ boot.kernelModules = [ "kvm-intel" ];
+
+ boot.loader.gummiboot.enable = true;
+ boot.loader.efi.canTouchEfiVariables = true;
+
+ networking.wireless.enable = true;
+
+ nix = {
+ buildCores = 4;
+ maxJobs = 4;
+ daemonIONiceLevel = 1;
+ daemonNiceLevel = 1;
+ };
+
+ services.logind.extraConfig = ''
+ HandleHibernateKey=ignore
+ HandleLidSwitch=ignore
+ HandlePowerKey=ignore
+ HandleSuspendKey=ignore
+ '';
+
+ system.activationScripts.powertopTunables = ''
+ echo 1 > /sys/module/snd_hda_intel/parameters/power_save
+ echo 1500 > /proc/sys/vm/dirty_writeback_centisecs
+ (cd /sys/bus/pci/devices
+ for i in *; do
+ echo auto > $i/power/control # defaults to 'on'
+ done)
+ '';
+}