summaryrefslogtreecommitdiffstats
path: root/tv/2configs/urlwatch.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tv/2configs/urlwatch.nix')
-rw-r--r--tv/2configs/urlwatch.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/tv/2configs/urlwatch.nix b/tv/2configs/urlwatch.nix
index 4fb11106..b2364e6e 100644
--- a/tv/2configs/urlwatch.nix
+++ b/tv/2configs/urlwatch.nix
@@ -7,6 +7,13 @@ with import <stockholm/lib>;
concatMapStringsSep " " shell.escape (toList args)
}";
};
+ xml = xml' ["--format" "-"];
+ xml' = args: url: {
+ inherit url;
+ filter = "system:${pkgs.libxml2}/bin/xmllint ${
+ concatMapStringsSep " " shell.escape (toList args)
+ }";
+ };
in {
krebs.urlwatch = {
enable = true;