summaryrefslogtreecommitdiffstats
path: root/tv/2configs/urlwatch.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tv/2configs/urlwatch.nix')
-rw-r--r--tv/2configs/urlwatch.nix16
1 files changed, 6 insertions, 10 deletions
diff --git a/tv/2configs/urlwatch.nix b/tv/2configs/urlwatch.nix
index b2364e6e..378b5d16 100644
--- a/tv/2configs/urlwatch.nix
+++ b/tv/2configs/urlwatch.nix
@@ -1,19 +1,15 @@
with import <stockholm/lib>;
{ config, pkgs, ... }: let
- json = json' ["."];
- json' = args: url: {
+ exec = filename: args: url: {
inherit url;
- filter = "system:${pkgs.jq}/bin/jq ${
- concatMapStringsSep " " shell.escape (toList args)
+ filter = "system:${
+ concatMapStringsSep " " shell.escape ([filename] ++ toList args)
}";
};
+ json = json' ["."];
+ json' = exec "${pkgs.jq}/bin/jq";
xml = xml' ["--format" "-"];
- xml' = args: url: {
- inherit url;
- filter = "system:${pkgs.libxml2}/bin/xmllint ${
- concatMapStringsSep " " shell.escape (toList args)
- }";
- };
+ xml' = exec "${pkgs.libxml2}/bin/xmllint";
in {
krebs.urlwatch = {
enable = true;