summaryrefslogtreecommitdiffstats
path: root/tv/2configs/test.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tv/2configs/test.nix')
-rw-r--r--tv/2configs/test.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/tv/2configs/test.nix b/tv/2configs/test.nix
new file mode 100644
index 00000000..f96b9e98
--- /dev/null
+++ b/tv/2configs/test.nix
@@ -0,0 +1,25 @@
+{ config, lib, pkgs, ... }:
+
+with import ../4lib { inherit lib pkgs; };
+
+let
+ tvpkgs = import ../5pkgs { inherit lib pkgs; };
+
+ out = {
+ security.sudo.extraConfig = ''
+ tv ALL=(test) NOPASSWD: ALL
+ '';
+ users.extraUsers.test = {
+ shell = "${test-shell}";
+ };
+ };
+
+ test-shell = tvpkgs.execve "test-shell" rec {
+ filename = "${pkgs.bash}/bin/bash";
+ argv = ["sh" "--noprofile" "-l"];
+ envp.ENV = pkgs.writeText "test-env" ''
+ ${shell.cat "Hello, `$(j0w\nd0g!)`!\\o/\n"} >&2
+ '';
+ };
+
+in out