summaryrefslogtreecommitdiffstats
path: root/tv/2configs/sub/xr.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tv/2configs/sub/xr.nix')
-rw-r--r--tv/2configs/sub/xr.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/tv/2configs/sub/xr.nix b/tv/2configs/sub/xr.nix
new file mode 100644
index 00000000..6c9cbb93
--- /dev/null
+++ b/tv/2configs/sub/xr.nix
@@ -0,0 +1,22 @@
+{ config, lib, pkgs, ... }:
+
+with lib;
+
+{
+ krebs.per-user.xr.packages = [
+ pkgs.cr
+ ];
+
+ security.sudo.extraConfig = "tv ALL=(xr) NOPASSWD: ALL";
+
+ users.users.xr = {
+ extraGroups = [
+ "audio"
+ "video"
+ ];
+ group = "subusers";
+ home = "/home/xr";
+ uid = 1660006127; # genid xr
+ useDefaultShell = true;
+ };
+}