summaryrefslogtreecommitdiffstats
path: root/tv/2configs/sshd.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tv/2configs/sshd.nix')
-rw-r--r--tv/2configs/sshd.nix22
1 files changed, 0 insertions, 22 deletions
diff --git a/tv/2configs/sshd.nix b/tv/2configs/sshd.nix
deleted file mode 100644
index 79af5b01..00000000
--- a/tv/2configs/sshd.nix
+++ /dev/null
@@ -1,22 +0,0 @@
-with import <stockholm/lib>;
-{ config, ... }: let
- cfg.host = config.krebs.build.host;
-in {
- services.openssh = {
- enable = true;
- };
- tv.iptables.input-internet-accept-tcp = singleton "ssh";
- tv.iptables.extra.nat.OUTPUT = [
- "-o lo -p tcp --dport 11423 -j REDIRECT --to-ports 22"
- ];
- tv.iptables.extra4.nat.PREROUTING = [
- "-d ${cfg.host.nets.retiolum.ip4.addr} -p tcp --dport 22 -j ACCEPT"
- ];
- tv.iptables.extra6.nat.PREROUTING = [
- "-d ${cfg.host.nets.retiolum.ip6.addr} -p tcp --dport 22 -j ACCEPT"
- ];
- tv.iptables.extra.nat.PREROUTING = [
- "-p tcp --dport 22 -j REDIRECT --to-ports 0"
- "-p tcp --dport 11423 -j REDIRECT --to-ports 22"
- ];
-}