summaryrefslogtreecommitdiffstats
path: root/tv/2configs/retiolum.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tv/2configs/retiolum.nix')
-rw-r--r--tv/2configs/retiolum.nix27
1 files changed, 0 insertions, 27 deletions
diff --git a/tv/2configs/retiolum.nix b/tv/2configs/retiolum.nix
deleted file mode 100644
index 1b176e0b..00000000
--- a/tv/2configs/retiolum.nix
+++ /dev/null
@@ -1,27 +0,0 @@
-with import ./lib;
-{ config, pkgs, ... }: {
- krebs.tinc.retiolum = {
- enable = true;
- connectTo = filter (ne config.krebs.build.host.name) [
- "ni"
- "prism"
- "eve"
- ];
- extraConfig = ''
- LocalDiscovery = yes
- '';
- tincPackage = pkgs.tinc_pre;
- tincUp = lib.mkIf config.systemd.network.enable "";
- };
- systemd.network.networks.retiolum = {
- matchConfig.Name = "retiolum";
- address = let
- inherit (config.krebs.build.host.nets.retiolum) ip4 ip6;
- in [
- "${ip4.addr}/${toString ip4.prefixLength}"
- "${ip6.addr}/${toString ip6.prefixLength}"
- ];
- };
- tv.iptables.input-internet-accept-tcp = singleton "tinc";
- tv.iptables.input-internet-accept-udp = singleton "tinc";
-}