summaryrefslogtreecommitdiffstats
path: root/tv/2configs/ppp.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tv/2configs/ppp.nix')
-rw-r--r--tv/2configs/ppp.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/tv/2configs/ppp.nix b/tv/2configs/ppp.nix
index ff61f943..c801401b 100644
--- a/tv/2configs/ppp.nix
+++ b/tv/2configs/ppp.nix
@@ -8,8 +8,10 @@
in {
assertions = [
{
- assertion = config.networking.resolvconf.enable;
- message = "ppp configuration needs resolvconf";
+ assertion =
+ config.networking.resolvconf.enable ||
+ config.networking.useNetworkd;
+ message = "ppp configuration needs resolvconf or networkd";
}
];
environment.etc."ppp/ip-up".source = pkgs.writeDash "ppp.ip-up" ''