summaryrefslogtreecommitdiffstats
path: root/tv/2configs/nginx/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tv/2configs/nginx/default.nix')
-rw-r--r--tv/2configs/nginx/default.nix15
1 files changed, 6 insertions, 9 deletions
diff --git a/tv/2configs/nginx/default.nix b/tv/2configs/nginx/default.nix
index b0acb943..efea3a84 100644
--- a/tv/2configs/nginx/default.nix
+++ b/tv/2configs/nginx/default.nix
@@ -4,22 +4,19 @@ with import <stockholm/lib>;
{
services.nginx = {
+ enableReload = true;
+
recommendedGzipSettings = true;
recommendedOptimisation = true;
recommendedTlsSettings = true;
- virtualHosts._http = {
+ virtualHosts.${toJSON ""} = {
default = true;
extraConfig = ''
- return 404;
- '';
- };
-
- virtualHosts.default = {
- locations."= /etc/os-release".extraConfig = ''
- default_type text/plain;
- alias /etc/os-release;
+ error_page 400 =444 /;
+ return 444;
'';
+ rejectSSL = true;
};
};
tv.iptables = {