summaryrefslogtreecommitdiffstats
path: root/tv/2configs/hw/winmax2.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tv/2configs/hw/winmax2.nix')
-rw-r--r--tv/2configs/hw/winmax2.nix20
1 files changed, 19 insertions, 1 deletions
diff --git a/tv/2configs/hw/winmax2.nix b/tv/2configs/hw/winmax2.nix
index 0a207f23..49af7611 100644
--- a/tv/2configs/hw/winmax2.nix
+++ b/tv/2configs/hw/winmax2.nix
@@ -1,7 +1,21 @@
{ pkgs, ... }: {
+
+ imports = [
+ ../smartd.nix
+ ];
+
boot.initrd.availableKernelModules = [ "nvme" "xhci_pci" "thunderbolt" "usbhid" ];
boot.initrd.kernelModules = [ "amdgpu" ];
- boot.kernelModules = [ "kvm-amd" ];
+ boot.kernelModules = [
+ "amd-pstate"
+ "kvm-amd"
+ ];
+ boot.kernelPackages = pkgs.linuxPackages_latest;
+ boot.kernelParams = [
+ "amd_pstate=passive"
+ ];
+
+ hardware.bluetooth.enable = true;
hardware.cpu.amd.updateMicrocode = true;
hardware.enableRedistributableFirmware = true;
@@ -25,6 +39,10 @@
services.illum.enable = true;
+ services.logind.extraConfig = /* ini */ ''
+ HandlePowerKey=ignore
+ '';
+
tv.lidControl.enable = true;
tv.hw.screens.primary.width = 2560;