summaryrefslogtreecommitdiffstats
path: root/tv/2configs/gitrepos.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tv/2configs/gitrepos.nix')
-rw-r--r--tv/2configs/gitrepos.nix12
1 files changed, 7 insertions, 5 deletions
diff --git a/tv/2configs/gitrepos.nix b/tv/2configs/gitrepos.nix
index 7e059cc4..b6480f35 100644
--- a/tv/2configs/gitrepos.nix
+++ b/tv/2configs/gitrepos.nix
@@ -90,26 +90,28 @@ let {
{
brain = {
collaborators = with config.krebs.users; [ lass makefu ];
- hooks.post-receive = irc-announce-retiolum;
+ hooks.post-receive = irc-announce {
+ cgit_endpoint = null;
+ };
};
} //
# TODO don't put secrets/repos.nix into the store
import <secrets/repos.nix> { inherit config lib pkgs; }
);
- irc-announce-retiolum = pkgs.git-hooks.irc-announce {
+ irc-announce = args: pkgs.git-hooks.irc-announce (recursiveUpdate {
+ channel = "#retiolum";
# TODO make nick = config.krebs.build.host.name the default
nick = config.krebs.build.host.name;
- channel = "#retiolum";
server = "ni.r";
verbose = true;
- };
+ } args);
make-public-repo = name: { cgit ? {}, ... }: {
inherit cgit name;
public = true;
hooks = optionalAttrs (config.krebs.build.host.name == "ni") {
- post-receive = irc-announce-retiolum;
+ post-receive = irc-announce {};
};
};