summaryrefslogtreecommitdiffstats
path: root/tv/2configs/consul-server.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tv/2configs/consul-server.nix')
-rw-r--r--tv/2configs/consul-server.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/tv/2configs/consul-server.nix b/tv/2configs/consul-server.nix
new file mode 100644
index 00000000..d10f9ea7
--- /dev/null
+++ b/tv/2configs/consul-server.nix
@@ -0,0 +1,21 @@
+{ config, ... }:
+
+{
+ tv.consul = rec {
+ enable = true;
+
+ self = config.krebs.build.host;
+ inherit (self) dc;
+
+ server = true;
+
+ hosts = with config.krebs.hosts; [
+ # TODO get this list automatically from each host where tv.consul.enable is true
+ cd
+ mkdir
+ nomic
+ rmdir
+ #wu
+ ];
+ };
+}