summaryrefslogtreecommitdiffstats
path: root/tv/2configs/autotether.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tv/2configs/autotether.nix')
-rw-r--r--tv/2configs/autotether.nix19
1 files changed, 0 insertions, 19 deletions
diff --git a/tv/2configs/autotether.nix b/tv/2configs/autotether.nix
deleted file mode 100644
index 43b5575c..00000000
--- a/tv/2configs/autotether.nix
+++ /dev/null
@@ -1,19 +0,0 @@
-{ config, pkgs, ... }: let
- cfg.serial = "17e064850405";
-in {
- systemd.services.usb_tether.serviceConfig = {
- SyslogIdentifier = "usb_tether";
- ExecStartPre = "${pkgs.android-tools}/bin/adb -s ${cfg.serial} wait-for-device";
- ExecStart = "${pkgs.android-tools}/bin/adb -s ${cfg.serial} shell svc usb setFunctions rndis";
- };
- services.udev.extraRules = /* sh */ ''
- ACTION=="add", SUBSYSTEM=="net", KERNEL=="usb*", NAME="android"
-
- ACTION=="add", SUBSYSTEM=="usb", ATTR{serial}=="${cfg.serial}", \
- TAG+="systemd", ENV{SYSTEMD_WANTS}="usb_tether.service"
- '';
- systemd.network.networks.android = {
- matchConfig.Name = "android";
- DHCP = "yes";
- };
-}