summaryrefslogtreecommitdiffstats
path: root/tv/1systems/nomic/config.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tv/1systems/nomic/config.nix')
-rw-r--r--tv/1systems/nomic/config.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/tv/1systems/nomic/config.nix b/tv/1systems/nomic/config.nix
index 86f9b7ec..38cc6236 100644
--- a/tv/1systems/nomic/config.nix
+++ b/tv/1systems/nomic/config.nix
@@ -17,9 +17,7 @@ with import <stockholm/lib>;
boot.initrd.luks = {
cryptoModules = [ "aes" "sha512" "xts" ];
- devices = [
- { name = "luks1"; device = "/dev/sda2"; }
- ];
+ devices.luks1.device = "/dev/sda2";
};
# Don't use UEFI because current disk was partitioned/formatted for AO753.
@@ -47,6 +45,8 @@ with import <stockholm/lib>;
fsType = "btrfs";
};
+ environment.homeBinInPath = true;
+
environment.systemPackages = with pkgs; [
(writeDashBin "play" ''
set -euf