summaryrefslogtreecommitdiffstats
path: root/shared/2configs/shared-buildbot.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shared/2configs/shared-buildbot.nix')
-rw-r--r--shared/2configs/shared-buildbot.nix18
1 files changed, 9 insertions, 9 deletions
diff --git a/shared/2configs/shared-buildbot.nix b/shared/2configs/shared-buildbot.nix
index a873c8e7..22144e9e 100644
--- a/shared/2configs/shared-buildbot.nix
+++ b/shared/2configs/shared-buildbot.nix
@@ -119,15 +119,15 @@
f = util.BuildFactory()
f.addStep(grab_repo)
- addShell(f,name="build-test-all-modules",env=env,
- command=nixshell + \
- ["mkdir -p /tmp/testbuild/$LOGNAME && touch /tmp/testbuild/$LOGNAME/.populate; \
- make \
- test \
- target=$LOGNAME@${config.krebs.build.host.name}/tmp/testbuild/$LOGNAME \
- method=build \
- system=test-all-krebs-modules"]
- )
+ for i in [ "test-all-krebs-modules", "wolf" ]:
+ addShell(f,name="build-{}".format(i),env=env,
+ command=nixshell + \
+ ["mkdir -p /tmp/testbuild/$LOGNAME && touch /tmp/testbuild/$LOGNAME/.populate; \
+ make \
+ test \
+ target=$LOGNAME@${config.krebs.build.host.name}/tmp/testbuild/$LOGNAME \
+ method=build \
+ system={}".format(i)])
bu.append(util.BuilderConfig(name="build-local",
slavenames=slavenames,