summaryrefslogtreecommitdiffstats
path: root/shared/2configs/shack/radioactive.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shared/2configs/shack/radioactive.nix')
-rw-r--r--shared/2configs/shack/radioactive.nix35
1 files changed, 0 insertions, 35 deletions
diff --git a/shared/2configs/shack/radioactive.nix b/shared/2configs/shack/radioactive.nix
deleted file mode 100644
index 378b5405..00000000
--- a/shared/2configs/shack/radioactive.nix
+++ /dev/null
@@ -1,35 +0,0 @@
-{ config, lib, pkgs, ... }:
-
-with import <stockholm/lib>;
-let
- pkg = pkgs.stdenv.mkDerivation {
- name = "radioactive-2017-06-01";
- src = pkgs.fetchgit {
- url = "https://github.com/makefu/nagios-radioactiveathome-plugins/";
- rev = "955f614";
- sha256 = "0ql6npl3n6shvij0ly6a52yjmf7dc31c5x29y927k9lvp8ygin20";
- };
- buildInputs = [
- (pkgs.python3.withPackages (pythonPackages: with pythonPackages; [
- docopt
- requests2
- python
- ]))
- ];
- installPhase = ''
- install -m755 -D add_many_points.py $out/bin/radioactive-add-many
- '';
- };
-in {
- systemd.services.radioactive = {
- description = "radioactive";
- wantedBy = [ "multi-user.target" ];
- serviceConfig = {
- User = "nobody"; # TODO separate user
- ExecStart = "${pkg}/bin/radioactive-add-many loop 60";
- Restart = "always";
- PrivateTmp = true;
- PermissionsStartOnly = true;
- };
- };
-}