summaryrefslogtreecommitdiffstats
path: root/shared/2configs/shack/nix-cacher.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shared/2configs/shack/nix-cacher.nix')
-rw-r--r--shared/2configs/shack/nix-cacher.nix31
1 files changed, 0 insertions, 31 deletions
diff --git a/shared/2configs/shack/nix-cacher.nix b/shared/2configs/shack/nix-cacher.nix
deleted file mode 100644
index 8feeca9a..00000000
--- a/shared/2configs/shack/nix-cacher.nix
+++ /dev/null
@@ -1,31 +0,0 @@
-{ config, pkgs, ... }:
-with import <stockholm/lib>;
-let
- cfg = config.krebs.apt-cacher-ng;
-in
-{
- imports = [
- ./bincache.nix
- ];
- krebs.apt-cacher-ng = {
- enable = true;
- port = 3142;
- bindAddress = "localhost";
- cacheExpiration = 30;
- };
-
- services.nginx = {
- enable = mkDefault true;
- virtualHosts.shack-nix-cacher = {
- serverAliases = [
- "acng.shack"
- ];
- locations."/".extraConfig = ''
- proxy_set_header Host $host;
- proxy_set_header X-Real-IP $remote_addr;
- proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
- proxy_pass http://localhost:${toString cfg.port}/;
- '';
- };
- };
-}