summaryrefslogtreecommitdiffstats
path: root/shared/2configs/shack/muell_caller.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shared/2configs/shack/muell_caller.nix')
-rw-r--r--shared/2configs/shack/muell_caller.nix41
1 files changed, 0 insertions, 41 deletions
diff --git a/shared/2configs/shack/muell_caller.nix b/shared/2configs/shack/muell_caller.nix
deleted file mode 100644
index 2d8d78e3..00000000
--- a/shared/2configs/shack/muell_caller.nix
+++ /dev/null
@@ -1,41 +0,0 @@
-{ config, lib, pkgs, ... }:
-
-with import <stockholm/lib>;
-let
- pkg = pkgs.stdenv.mkDerivation {
- name = "muell_caller-2017-06-01";
- src = pkgs.fetchgit {
- url = "https://github.com/shackspace/muell_caller/";
- rev = "bbd4009";
- sha256 = "1bfnfl2vdh0p5wzyz5p48qh04vvsg2445avg86fzhzragx25fqv0";
- };
- buildInputs = [
- (pkgs.python3.withPackages (pythonPackages: with pythonPackages; [
- docopt
- requests2
- paramiko
- python
- ]))
- ];
- installPhase = ''
- install -m755 -D call.py $out/bin/call-muell
- '';
- };
- cfg = "${toString <secrets>}/tell.json";
-in {
- systemd.services.call_muell = {
- description = "call muell";
- wantedBy = [ "multi-user.target" ];
- serviceConfig = {
- User = "nobody"; # TODO separate user
- ExecStartPre = pkgs.writeDash "call-muell-pre" ''
- cp ${cfg} /tmp/tell.json
- chown nobody /tmp/tell.json
- '';
- ExecStart = "${pkg}/bin/call-muell --cfg /tmp/tell.json --mode mpd loop 60";
- Restart = "always";
- PrivateTmp = true;
- PermissionsStartOnly = true;
- };
- };
-}