summaryrefslogtreecommitdiffstats
path: root/shared/2configs/shack/mqtt_sub.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shared/2configs/shack/mqtt_sub.nix')
-rw-r--r--shared/2configs/shack/mqtt_sub.nix34
1 files changed, 0 insertions, 34 deletions
diff --git a/shared/2configs/shack/mqtt_sub.nix b/shared/2configs/shack/mqtt_sub.nix
deleted file mode 100644
index a8427dde..00000000
--- a/shared/2configs/shack/mqtt_sub.nix
+++ /dev/null
@@ -1,34 +0,0 @@
-{ config, lib, pkgs, ... }:
-
-with import <stockholm/lib>;
-let
- pkg = pkgs.stdenv.mkDerivation {
- name = "mqtt2graphite-2017-05-29";
- src = pkgs.fetchgit {
- url = "https://github.com/shackspace/mqtt2graphite/";
- rev = "117179d";
- sha256 = "1334jbbzlqizyp7zcn4hdswhhrnkj1p4p435n5nph82lzffrsi44";
- };
- buildInputs = [
- (pkgs.python35.withPackages (pythonPackages: with pythonPackages; [
- docopt
- paho-mqtt
- ]))
- ];
- installPhase = ''
- install -m755 -D sub.py $out/bin/sub
- install -m755 -D sub2.py $out/bin/sub-new
- '';
- };
-in {
- systemd.services.mqtt_sub = {
- description = "subscribe to mqtt, send to graphite";
- # after = [ (lib.optional config.services.mosqitto.enable "mosquitto.service") ];
- wantedBy = [ "multi-user.target" ];
- serviceConfig = {
- User = "nobody";
- ExecStart = "${pkg}/bin/sub-new";
- PrivateTmp = true;
- };
- };
-}