summaryrefslogtreecommitdiffstats
path: root/shared/2configs/buildbot-standalone.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shared/2configs/buildbot-standalone.nix')
-rw-r--r--shared/2configs/buildbot-standalone.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/shared/2configs/buildbot-standalone.nix b/shared/2configs/buildbot-standalone.nix
new file mode 100644
index 00000000..adf44cad
--- /dev/null
+++ b/shared/2configs/buildbot-standalone.nix
@@ -0,0 +1,31 @@
+{ lib, config, pkgs, ... }:
+let
+ pkgs-unst = import (fetchTarball https://github.com/NixOS/nixpkgs-channels/archive/nixos-unstable.tar.gz) {};
+in {
+ nixpkgs.config.packageOverrides = pkgs: {
+ buildbot = pkgs-unst.buildbot;
+ buildbot-slave = pkgs-unst.buildbot-slave;
+ };
+ networking.firewall.allowedTCPPorts = [ 8010 ];
+ krebs.buildbot.master = {
+ enable = true;
+ irc = {
+ enable = true;
+ server = "cd.retiolum";
+ channel = "retiolum";
+ allowForce = true;
+ };
+ extraConfig = ''
+ c['buildbotURL'] = "http://${config.krebs.build.host.name}:8010/"
+ '';
+ };
+
+ krebs.buildbot.slave = {
+ enable = true;
+ masterhost = "localhost";
+ username = "testslave";
+ password = "krebspass";
+ packages = with pkgs;[ git nix ];
+ extraEnviron = { NIX_PATH="nixpkgs=${toString <nixpkgs>}"; };
+ };
+}