summaryrefslogtreecommitdiffstats
path: root/shared/1systems/test-minimal-deploy/config.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shared/1systems/test-minimal-deploy/config.nix')
-rw-r--r--shared/1systems/test-minimal-deploy/config.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/shared/1systems/test-minimal-deploy/config.nix b/shared/1systems/test-minimal-deploy/config.nix
new file mode 100644
index 00000000..eab70367
--- /dev/null
+++ b/shared/1systems/test-minimal-deploy/config.nix
@@ -0,0 +1,16 @@
+{ config, pkgs, lib, ... }:
+{
+ imports = [
+ <stockholm/shared>
+ ];
+ krebs = {
+ enable = true;
+ build.user = config.krebs.users.shared;
+ build.host = config.krebs.hosts.test-all-krebs-modules;
+ };
+ # just get the system to eval in nixos without errors
+ boot.loader.grub.devices = ["/dev/sda"];
+ fileSystems."/" = {
+ device = "/dev/lol";
+ };
+}