summaryrefslogtreecommitdiffstats
path: root/old/modules/uriel/repos.nix
diff options
context:
space:
mode:
Diffstat (limited to 'old/modules/uriel/repos.nix')
-rw-r--r--old/modules/uriel/repos.nix78
1 files changed, 78 insertions, 0 deletions
diff --git a/old/modules/uriel/repos.nix b/old/modules/uriel/repos.nix
new file mode 100644
index 00000000..e31ba948
--- /dev/null
+++ b/old/modules/uriel/repos.nix
@@ -0,0 +1,78 @@
+{ ... }:
+
+{
+ imports = [
+ ../lass/gitolite-base.nix
+ ../common/krebs-keys.nix
+ ../common/krebs-repos.nix
+ ];
+
+ services.gitolite = {
+ repos = {
+
+ config = {
+ users = {
+ lass = "RW+";
+ uriel = "R";
+ tv = "R";
+ };
+ extraConfig = "option hook.post-receive = irc-announce";
+ };
+
+ pass = {
+ users = {
+ lass = "RW+";
+ uriel = "R";
+ };
+ };
+
+ load-env = {
+ users = {
+ lass = "RW+";
+ uriel = "R";
+ tv = "R";
+ };
+ extraConfig = "option hook.post-receive = irc-announce";
+ };
+
+ emse-hsdb = {
+ users = {
+ lass = "RW+";
+ uriel = "R";
+ tv = "R";
+ };
+ extraConfig = "option hook.post-receive = irc-announce";
+ };
+
+ brain = {
+ users = {
+ lass = "RW+";
+ };
+ extraConfig = "option hook.post-receive = irc-announce";
+ #hooks.post-receive = irc-announce;
+ };
+
+ painload = {
+ users = {
+ lass = "RW+";
+ };
+ extraConfig = "option hook.post-receive = irc-announce";
+ };
+
+ services = {
+ users = {
+ lass = "RW+";
+ };
+ extraConfig = "option hook.post-receive = irc-announce";
+ };
+
+ xmonad-config = {
+ users = {
+ lass = "RW+";
+ uriel = "R";
+ };
+ };
+
+ };
+ };
+}