summaryrefslogtreecommitdiffstats
path: root/old/modules/tv/urxvt.nix
diff options
context:
space:
mode:
Diffstat (limited to 'old/modules/tv/urxvt.nix')
-rw-r--r--old/modules/tv/urxvt.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/old/modules/tv/urxvt.nix b/old/modules/tv/urxvt.nix
new file mode 100644
index 00000000..a9758124
--- /dev/null
+++ b/old/modules/tv/urxvt.nix
@@ -0,0 +1,24 @@
+{ pkgs, ... }:
+
+ with builtins;
+
+let
+ users = [ "tv" ];
+ urxvt = pkgs.rxvt_unicode;
+ mkService = user: {
+ description = "urxvt terminal daemon";
+ wantedBy = [ "multi-user.target" ];
+ restartIfChanged = false;
+ serviceConfig = {
+ Restart = "always";
+ User = user;
+ ExecStart = "${urxvt}/bin/urxvtd";
+ };
+ };
+
+in
+
+{
+ environment.systemPackages = [ urxvt ];
+ systemd.services = listToAttrs (map (u: { name = "${u}-urxvtd"; value = mkService u; }) users);
+}