summaryrefslogtreecommitdiffstats
path: root/old/modules/tv/iptables/options.nix
diff options
context:
space:
mode:
Diffstat (limited to 'old/modules/tv/iptables/options.nix')
-rw-r--r--old/modules/tv/iptables/options.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/old/modules/tv/iptables/options.nix b/old/modules/tv/iptables/options.nix
new file mode 100644
index 00000000..1adffebd
--- /dev/null
+++ b/old/modules/tv/iptables/options.nix
@@ -0,0 +1,29 @@
+{ lib, ... }:
+
+let
+ inherit (lib) mkOption types;
+in
+
+{
+ enable = mkOption {
+ type = types.bool;
+ default = false;
+ description = "Enable iptables.";
+ };
+
+ input-internet-accept-new-tcp = mkOption {
+ type = with types; listOf str;
+ default = [];
+ description = ''
+ TCP ports, accepting incoming connections from anywhere.
+ '';
+ };
+
+ input-retiolum-accept-new-tcp = mkOption {
+ type = with types; listOf str;
+ default = [];
+ description = ''
+ TCP ports, accepting incoming connections from Retiolum.
+ '';
+ };
+}