summaryrefslogtreecommitdiffstats
path: root/old/modules/tv/config/consul-server.nix
diff options
context:
space:
mode:
Diffstat (limited to 'old/modules/tv/config/consul-server.nix')
-rw-r--r--old/modules/tv/config/consul-server.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/old/modules/tv/config/consul-server.nix b/old/modules/tv/config/consul-server.nix
new file mode 100644
index 00000000..4cedbd34
--- /dev/null
+++ b/old/modules/tv/config/consul-server.nix
@@ -0,0 +1,22 @@
+{ config, ... }:
+
+{
+ imports = [ ../../tv/consul ];
+ tv.consul = rec {
+ enable = true;
+
+ inherit (config.tv.identity) self;
+ inherit (self) dc;
+
+ server = true;
+
+ hosts = with config.tv.identity.hosts; [
+ # TODO get this list automatically from each host where tv.consul.enable is true
+ cd
+ mkdir
+ nomic
+ rmdir
+ #wu
+ ];
+ };
+}