summaryrefslogtreecommitdiffstats
path: root/old/modules/mors/git.nix
diff options
context:
space:
mode:
Diffstat (limited to 'old/modules/mors/git.nix')
-rw-r--r--old/modules/mors/git.nix71
1 files changed, 71 insertions, 0 deletions
diff --git a/old/modules/mors/git.nix b/old/modules/mors/git.nix
new file mode 100644
index 00000000..1dd61d16
--- /dev/null
+++ b/old/modules/mors/git.nix
@@ -0,0 +1,71 @@
+{ config, lib, pkgs, ... }:
+
+{
+ imports = [
+ ../tv/git
+ ];
+
+ services.git =
+ let
+ inherit (builtins) readFile;
+ # TODO lib should already include our stuff
+ inherit (import ../../lib { inherit lib pkgs; }) addNames git;
+
+ krebs-private = name: desc:
+ {
+ inherit desc;
+ hooks = {
+ post-receive = git.irc-announce {
+ nick = config.networking.hostName; # TODO make this the default
+ channel = "#retiolum";
+ server = "ire.retiolum";
+ };
+ };
+ }
+ in rec {
+ enable = true;
+
+ users = addNames {
+ tv = { pubkey = readFile <pubkeys/tv.ssh.pub>; };
+ lass = { pubkey = readFile <pubkeys/lass.ssh.pub>; };
+ uriel = { pubkey = readFile <pubkeys/lass.ssh.pub>; };
+ makefu = { pubkey = "xxx"; };
+ };
+
+ repos = addNames {
+ shitment = {
+ desc = "shitment repository";
+ hooks = {
+ post-receive = git.irc-announce {
+ nick = config.networking.hostName; # TODO make this the default
+ channel = "#retiolum";
+ server = "ire.retiolum";
+ };
+ };
+ public = true;
+ };
+ testing = {
+ desc = "testing repository";
+ hooks = {
+ post-receive = git.irc-announce {
+ nick = config.networking.hostName; # TODO make this the default
+ channel = "#repository";
+ server = "ire.retiolum";
+ };
+ };
+ public = true;
+ };
+ };
+
+ rules = with git; with users; with repos; [
+ { user = lass;
+ repo = [ testing shitment ];
+ perm = push master [ non-fast-forward create delete merge ];
+ }
+ { user = [ tv uriel makefu ];
+ repo = [ testing shitment ];
+ perm = fetch;
+ }
+ ];
+ };
+}