summaryrefslogtreecommitdiffstats
path: root/old/modules/lass/xresources.nix
diff options
context:
space:
mode:
Diffstat (limited to 'old/modules/lass/xresources.nix')
-rw-r--r--old/modules/lass/xresources.nix57
1 files changed, 57 insertions, 0 deletions
diff --git a/old/modules/lass/xresources.nix b/old/modules/lass/xresources.nix
new file mode 100644
index 00000000..00a9e5c9
--- /dev/null
+++ b/old/modules/lass/xresources.nix
@@ -0,0 +1,57 @@
+{ config, lib, pkgs, ... }:
+
+#TODO:
+#prefix with Attribute Name
+#ex: urxvt
+
+#
+#
+with builtins;
+with lib;
+
+
+let
+
+ inherit (import ../../lib { inherit pkgs; inherit lib; }) shell-escape;
+ inherit (pkgs) writeScript;
+
+in
+
+{
+
+ options = {
+ services.xresources.enable = mkOption {
+ type = types.bool;
+ default = false;
+ description = ''
+ Whether to enable the automatic loading of Xresources definitions at display-manager start;
+ '';
+ };
+
+ services.xresources.resources = mkOption {
+ default = {};
+ type = types.attrsOf types.str;
+ example = {
+ urxvt = ''
+ URxvt*scrollBar: false
+ URxvt*urgentOnBell: true
+ '';
+ };
+ description = ''
+ Xresources definitions.
+ '';
+ };
+ };
+
+ config =
+ let
+ cfg = config.services.xresources;
+ xres = concatStringsSep "\n" (attrValues cfg.resources);
+
+ in mkIf cfg.enable {
+ services.xserver.displayManager.sessionCommands = ''
+ echo ${shell-escape xres} | xrdb -merge
+ '';
+ };
+
+}