summaryrefslogtreecommitdiffstats
path: root/old/modules/lass/urxvt.nix
diff options
context:
space:
mode:
Diffstat (limited to 'old/modules/lass/urxvt.nix')
-rw-r--r--old/modules/lass/urxvt.nix40
1 files changed, 40 insertions, 0 deletions
diff --git a/old/modules/lass/urxvt.nix b/old/modules/lass/urxvt.nix
new file mode 100644
index 00000000..889f768a
--- /dev/null
+++ b/old/modules/lass/urxvt.nix
@@ -0,0 +1,40 @@
+{ config, pkgs, ... }:
+
+let
+ inherit (config.users.extraUsers) mainUser;
+
+in
+
+{
+ imports = [
+ ./urxvtd.nix
+ ./xresources.nix
+ ];
+
+ services.urxvtd = {
+ enable = true;
+ users = [ mainUser.name ];
+ urxvtPackage = pkgs.rxvt_unicode_with-plugins;
+ };
+ services.xresources.enable = true;
+ services.xresources.resources.urxvt = ''
+ URxvt*scrollBar: false
+ URxvt*urgentOnBell: true
+ URxvt*font: -*-clean-*-*-*-*-*-*-*-*-*-*-iso10646-*
+ URxvt*boldFont: -*-clean-*-*-*-*-*-*-*-*-*-*-iso10646-*
+ URxvt.perl-ext-common: default,clipboard,url-select,keyboard-select
+ URxvt.url-select.launcher: browser-select
+ URxvt.url-select.underline: true
+ URxvt.keysym.M-u: perl:url-select:select_next
+ URxvt.keysym.M-Escape: perl:keyboard-select:activate
+ URxvt.keysym.M-s: perl:keyboard-select:search
+
+ URxvt.intensityStyles: false
+
+ URxvt*background: #000000
+ URxvt*foreground: #ffffff
+
+ !change unreadable blue
+ URxvt*color4: #268bd2
+ '';
+}