summaryrefslogtreecommitdiffstats
path: root/old/modules/lass/steam.nix
diff options
context:
space:
mode:
Diffstat (limited to 'old/modules/lass/steam.nix')
-rw-r--r--old/modules/lass/steam.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/old/modules/lass/steam.nix b/old/modules/lass/steam.nix
new file mode 100644
index 00000000..d54873b1
--- /dev/null
+++ b/old/modules/lass/steam.nix
@@ -0,0 +1,29 @@
+{ config, pkgs, ... }:
+
+{
+
+ imports = [
+ ./games.nix
+ ];
+ #
+ # Steam stuff
+ # source: https://nixos.org/wiki/Talk:Steam
+ #
+ ##TODO: make steam module
+ hardware.opengl.driSupport32Bit = true;
+
+ environment.systemPackages = with pkgs; [
+ steam
+ ];
+ networking.firewall = {
+ allowedUDPPorts = [
+ 27031
+ 27036
+ ];
+ allowedTCPPorts = [
+ 27036
+ 27037
+ ];
+ };
+
+}