summaryrefslogtreecommitdiffstats
path: root/old/modules/lass/chromium-patched.nix
diff options
context:
space:
mode:
Diffstat (limited to 'old/modules/lass/chromium-patched.nix')
-rw-r--r--old/modules/lass/chromium-patched.nix48
1 files changed, 48 insertions, 0 deletions
diff --git a/old/modules/lass/chromium-patched.nix b/old/modules/lass/chromium-patched.nix
new file mode 100644
index 00000000..71518177
--- /dev/null
+++ b/old/modules/lass/chromium-patched.nix
@@ -0,0 +1,48 @@
+{ config, pkgs, ... }:
+
+#settings to test:
+#
+ #"ForceEphemeralProfiles": true,
+let
+ masterPolicy = pkgs.writeText "master.json" ''
+ {
+ "PasswordManagerEnabled": false,
+ "DefaultGeolocationSetting": 2,
+ "RestoreOnStartup": 1,
+ "AutoFillEnabled": false,
+ "BackgroundModeEnabled": false,
+ "DefaultBrowserSettingEnabled": false,
+ "SafeBrowsingEnabled": false,
+ "ExtensionInstallForcelist": [
+ "cjpalhdlnbpafiamejdnhcphjbkeiagm;https://clients2.google.com/service/update2/crx",
+ "ihlenndgcmojhcghmfjfneahoeklbjjh;https://clients2.google.com/service/update2/crx"
+ ]
+ }
+ '';
+
+ master_preferences = pkgs.writeText "master_preferences" ''
+ {
+ "browser": {
+ "custom_chrome_frame": true
+ },
+
+ "extensions": {
+ "theme": {
+ "id": "",
+ "use_system": true
+ }
+ }
+ }
+ '';
+in {
+ environment.etc."chromium/policies/managed/master.json".source = pkgs.lib.mkForce masterPolicy;
+
+ environment.systemPackages = [
+ #pkgs.chromium
+ (pkgs.lib.overrideDerivation pkgs.chromium (attrs: {
+ buildCommand = attrs.buildCommand + ''
+ touch $out/TEST123
+ '';
+ }))
+ ];
+}