summaryrefslogtreecommitdiffstats
path: root/old/lib/modules.nix
diff options
context:
space:
mode:
Diffstat (limited to 'old/lib/modules.nix')
-rw-r--r--old/lib/modules.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/old/lib/modules.nix b/old/lib/modules.nix
new file mode 100644
index 00000000..248e638e
--- /dev/null
+++ b/old/lib/modules.nix
@@ -0,0 +1,21 @@
+let
+ pkgs = import <nixpkgs> {};
+ inherit (pkgs.lib) concatMap hasAttr;
+in rec {
+
+ no-touch-args = {
+ config = throw "no-touch-args: can't touch config!";
+ lib = throw "no-touch-args: can't touch lib!";
+ pkgs = throw "no-touch-args: can't touch pkgs!";
+ };
+
+ # list-imports : path -> [path]
+ # Return a module's transitive list of imports.
+ # XXX duplicates won't get eliminated from the result.
+ list-imports = path:
+ let module = import path no-touch-args;
+ imports = if hasAttr "imports" module
+ then concatMap list-imports module.imports
+ else [];
+ in [path] ++ imports;
+}