summaryrefslogtreecommitdiffstats
path: root/modules/nginx.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/nginx.nix')
-rw-r--r--modules/nginx.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/modules/nginx.nix b/modules/nginx.nix
new file mode 100644
index 00000000..8b420613
--- /dev/null
+++ b/modules/nginx.nix
@@ -0,0 +1,30 @@
+{ config, pkgs, ... }:
+
+{
+ services.nginx =
+ let
+ name = config.networking.hostName;
+ qname = "${name}.retiolum";
+ in
+ {
+ enable = true;
+ httpConfig = ''
+ sendfile on;
+ server {
+ listen 80;
+ server_name ${name} ${qname} localhost;
+ root /srv/http/${name};
+ location ~ ^/~(.+?)(/.*)?$ {
+ alias /home/$1/public_html$2;
+ }
+ }
+ types {
+ text/css css;
+ text/html html;
+ image/svg+xml svg;
+ }
+ default_type text/html;
+ charset utf-8;
+ '';
+ };
+}