summaryrefslogtreecommitdiffstats
path: root/mb/1systems/orange/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'mb/1systems/orange/configuration.nix')
-rw-r--r--mb/1systems/orange/configuration.nix9
1 files changed, 5 insertions, 4 deletions
diff --git a/mb/1systems/orange/configuration.nix b/mb/1systems/orange/configuration.nix
index 4ac0996a..3e90f89a 100644
--- a/mb/1systems/orange/configuration.nix
+++ b/mb/1systems/orange/configuration.nix
@@ -27,15 +27,13 @@ in {
fileSystems."/".options = [ "noatime" "nodiratime" "discard" ];
fileSystems."/mnt/public" = {
- device = "//192.168.88.252/public";
+ device = "//192.168.0.4/public";
fsType = "cifs";
options = let
automount_opts = "x-systemd.automount,noauto,x-systemd.idle-timeout=60,x-systemd.device-timeout=5s,x-systemd.mount-timeout=5s";
in [ "${automount_opts},user,rw,username=mb0,iocharset=utf8,credentials=${config.users.users.mb.home}/.smbcredentials" ];
};
- #networking.hostName = "0r4n93";
- networking.wireless.enable = false;
# Select internationalisation properties.
i18n = {
@@ -132,7 +130,6 @@ in {
vulnix
wcalc
wget
- wireshark-gtk
xz
];
@@ -151,6 +148,8 @@ in {
sound.enable = true;
hardware.pulseaudio.enable = true;
+ hardware.pulseaudio.support32Bit = true;
+ nixpkgs.config.pulseaudio = true;
services.xserver = {
enable = true;
@@ -173,7 +172,9 @@ in {
#services.openssh.permitRootLogin = "yes";
services.openssh.passwordAuthentication = false;
+ networking.wireless.enable = false;
networking.networkmanager.enable = false;
+ krebs.iptables.enable = true;
#networking.nameservers = [ "8.8.8.8" "141.1.1.1" ];
networking.enableIPv6 = false;