summaryrefslogtreecommitdiffstats
path: root/makefu/5pkgs/devpi/py3-fix-encoding.patch
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/5pkgs/devpi/py3-fix-encoding.patch')
-rw-r--r--makefu/5pkgs/devpi/py3-fix-encoding.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/makefu/5pkgs/devpi/py3-fix-encoding.patch b/makefu/5pkgs/devpi/py3-fix-encoding.patch
new file mode 100644
index 00000000..e5f94069
--- /dev/null
+++ b/makefu/5pkgs/devpi/py3-fix-encoding.patch
@@ -0,0 +1,11 @@
++++ a/setup.py
+--- b/setup.py
+@@ -26,7 +26,7 @@
+
+
+ def get_changelog():
+- text = open(os.path.join(here, 'CHANGELOG')).read()
++ text = open(os.path.join(here, 'CHANGELOG'),encoding='utf-8').read()
+ header_matches = list(re.finditer('^-+$', text, re.MULTILINE))
+ # until fifth header
+ text = text[:header_matches[5].start()]