summaryrefslogtreecommitdiffstats
path: root/makefu/5pkgs/custom
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/5pkgs/custom')
-rw-r--r--makefu/5pkgs/custom/alsa-tools/default.nix26
-rw-r--r--makefu/5pkgs/custom/hydra-check/default.nix19
-rw-r--r--makefu/5pkgs/custom/liveproxy/default.nix30
-rw-r--r--makefu/5pkgs/custom/mediawiki-matrix-bot/default.nix22
-rw-r--r--makefu/5pkgs/custom/qcma/default.nix57
-rw-r--r--makefu/5pkgs/custom/quodlibet/remove-override-warning.patch54
-rw-r--r--makefu/5pkgs/custom/quodlibet/single-digit-discnumber.patch13
7 files changed, 0 insertions, 221 deletions
diff --git a/makefu/5pkgs/custom/alsa-tools/default.nix b/makefu/5pkgs/custom/alsa-tools/default.nix
deleted file mode 100644
index 386b0870..00000000
--- a/makefu/5pkgs/custom/alsa-tools/default.nix
+++ /dev/null
@@ -1,26 +0,0 @@
-{stdenv, lib, alsaToolTarget,fetchurl, alsaLib, ncurses, fltk13, gtk3}:
-
-stdenv.mkDerivation rec {
- name = "alsa-${alsaToolTarget}-${version}";
- alsaToolsName = "alsa-tools-${version}";
- version = "1.0.29";
-
- src = fetchurl {
- urls = [
- "ftp://ftp.alsa-project.org/pub/tools/${alsaToolsName}.tar.bz2"
- "http://alsa.cybermirror.org/tools/${alsaToolsName}.tar.bz2"
-
- ];
- sha256 = "1lgvyb81md25s9ciswpdsbibmx9s030kvyylf0673w3kbamz1awl";
- };
- sourceRoot = "${alsaToolsName}/${alsaToolTarget}/";
- buildInputs = [ alsaLib fltk13 gtk3 ncurses ];
-
- meta = {
- homepage = http://www.alsa-project.org/;
- description = "ALSA tools - ${name}";
-
- platforms = lib.platforms.linux;
- maintainers = [ lib.maintainers.makefu ];
- };
-}
diff --git a/makefu/5pkgs/custom/hydra-check/default.nix b/makefu/5pkgs/custom/hydra-check/default.nix
deleted file mode 100644
index cfaaaab7..00000000
--- a/makefu/5pkgs/custom/hydra-check/default.nix
+++ /dev/null
@@ -1,19 +0,0 @@
-{ docopt, requests, beautifulsoup4, fetchFromGitHub, buildPythonPackage }:
-
-buildPythonPackage rec {
- name = "hydra-check";
- version = "1.1.0";
-
- src = fetchFromGitHub {
- owner = "nix-community";
- repo = "hydra-check";
- rev = version;
- sha256 = "1q4n5l238lnzcms3z1ax4860inaliawqlxv7nf1wb4knl4wr26fk";
- };
- propagatedBuildInputs = [
- docopt
- requests
- beautifulsoup4
- ];
- doCheck = false; # no tests
-}
diff --git a/makefu/5pkgs/custom/liveproxy/default.nix b/makefu/5pkgs/custom/liveproxy/default.nix
deleted file mode 100644
index ba5ddee6..00000000
--- a/makefu/5pkgs/custom/liveproxy/default.nix
+++ /dev/null
@@ -1,30 +0,0 @@
-{ lib
-, buildPythonPackage
-, fetchPypi
-, streamlink
-}:
-
-buildPythonPackage rec {
- pname = "liveproxy";
- version = "0.3.0";
-
- src = fetchPypi {
- inherit pname version;
- sha256 = "70ba2f7b57cdf19c6d971a434ed47cccb5fdfe4621baa76a3f6221e75b7f2729";
- };
-
- # # Package conditions to handle
- # # might have to sed setup.py and egg.info in patchPhase
- # # sed -i "s/<package>.../<package>/"
- # streamlink (>=1.1.1)
- propagatedBuildInputs = [
- streamlink
- ];
-
- meta = with lib; {
- description = "LiveProxy is a local Proxyserver between Streamlink and an URL";
- homepage = https://github.com/back-to/liveproxy;
- license = lib.licenses.bsd2;
- # maintainers = [ maintainers. ];
- };
-}
diff --git a/makefu/5pkgs/custom/mediawiki-matrix-bot/default.nix b/makefu/5pkgs/custom/mediawiki-matrix-bot/default.nix
deleted file mode 100644
index 4a91a916..00000000
--- a/makefu/5pkgs/custom/mediawiki-matrix-bot/default.nix
+++ /dev/null
@@ -1,22 +0,0 @@
-{ buildPythonApplication, fetchFromGitHub, feedparser, matrix-nio, docopt, aiohttp, aiofiles,
-mypy }:
-
-buildPythonApplication rec {
- pname = "mediawiki-matrix-bot";
- version = "1.0.0";
- src = fetchFromGitHub {
- owner = "nix-community";
- repo = "mediawiki-matrix-bot";
- rev = "v${version}";
- sha256 = "1923097j1xh34jmm0zhmvma614jcxaagj89c1fc1j2qyv14ybsvs";
- };
- propagatedBuildInputs = [
- feedparser matrix-nio docopt aiohttp aiofiles
- ];
- nativeBuildInputs = [
- mypy
- ];
- checkPhase = ''
- mypy --strict mediawiki_matrix_bot
- '';
-}
diff --git a/makefu/5pkgs/custom/qcma/default.nix b/makefu/5pkgs/custom/qcma/default.nix
deleted file mode 100644
index 670822f3..00000000
--- a/makefu/5pkgs/custom/qcma/default.nix
+++ /dev/null
@@ -1,57 +0,0 @@
-{ lib, stdenv, fetchFromGitHub, fetchgit, libusb, libtool, autoconf, pkgconfig, git,
-gettext, automake, libxml2
-, autoreconfHook
-, qmake4Hook
-, qmake
-, qtbase, qttools, qtmultimedia, libnotify, ffmpeg, gdk_pixbuf }:
-let
- libvitamtp = stdenv.mkDerivation rec {
- name = "libvitamtp-${version}";
- version = "2.5.9";
-
- src = fetchFromGitHub {
- owner = "codestation";
- repo = "vitamtp";
- rev = "v"+version;
- sha256 = "09c9f7gqpyicfpnhrfb4r67s2hci6hh31bzmqlpds4fywv5mzaf8";
- };
-
- buildInputs = [ libusb libxml2 libtool autoconf automake gettext pkgconfig
- autoreconfHook ];
-
- meta = {
- description = "Content Manager Assistant for the PS Vita";
- homepage = https://github.com/codestation/qcma;
- license = lib.licenses.gpl2;
- platforms = lib.platforms.linux;
- maintainers = with lib.maintainers; [ makefu ];
- };
- };
-in stdenv.mkDerivation rec {
- name = "qcma-${version}";
- version = "8e6cafedc0f47733f33323f829624e3fc847a176";
-
- src = fetchFromGitHub {
- owner = "codestation";
- repo = "qcma";
- rev = version;
- sha256 = "1l95kx3x4pf5iwmwigbch5c6n2h27lls5qiy4xh15v59p5442yw5";
- };
-
- preConfigure = ''
- lrelease common/resources/translations/*.ts
- '';
-
- enableParallelBuilding = true;
-
- buildInputs = [ gdk_pixbuf ffmpeg libnotify libvitamtp git qtmultimedia qtbase ];
- nativeBuildInputs = [ qttools pkgconfig qmake ];
-
- meta = {
- description = "Content Manager Assistant for the PS Vita";
- homepage = https://github.com/codestation/qcma;
- license = lib.licenses.gpl2;
- platforms = lib.platforms.linux;
- maintainers = with lib.maintainers; [ makefu ];
- };
-}
diff --git a/makefu/5pkgs/custom/quodlibet/remove-override-warning.patch b/makefu/5pkgs/custom/quodlibet/remove-override-warning.patch
deleted file mode 100644
index 0f9d4102..00000000
--- a/makefu/5pkgs/custom/quodlibet/remove-override-warning.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-diff --git a/quodlibet/qltk/edittags.py b/quodlibet/quodlibet/qltk/edittags.py
-index 148866ef7..e741b9c3d 100644
---- a/quodlibet/qltk/edittags.py
-+++ b/quodlibet/qltk/edittags.py
-@@ -740,13 +740,6 @@ class EditTags(Gtk.VBox):
- win.show()
- all_done = False
- for song in songs:
-- if not song.valid():
-- win.hide()
-- dialog = OverwriteWarning(self, song)
-- resp = dialog.run()
-- win.show()
-- if resp != OverwriteWarning.RESPONSE_SAVE:
-- break
-
- changed = False
- for key, values in iteritems(updated):
-diff --git a/quodlibet/qltk/tagsfrompath.py b/quodlibet/quodlibet/qltk/tagsfrompath.py
-index fd3f0709c..cb5b44f20 100644
---- a/quodlibet/qltk/tagsfrompath.py
-+++ b/quodlibet/qltk/tagsfrompath.py
-@@ -284,13 +284,6 @@ class TagsFromPath(Gtk.VBox):
- for entry in ((model and itervalues(model)) or []):
- song = entry.song
- changed = False
-- if not song.valid():
-- win.hide()
-- dialog = OverwriteWarning(self, song)
-- resp = dialog.run()
-- win.show()
-- if resp != OverwriteWarning.RESPONSE_SAVE:
-- break
-
- for i, h in enumerate(pattern.headers):
- text = entry.get_match(h)
-diff --git a/quodlibet/qltk/tracknumbers.py b/quodlibet/quodlibet/qltk/tracknumbers.py
-index 1ab4d0b9a..52f087db4 100644
---- a/quodlibet/qltk/tracknumbers.py
-+++ b/quodlibet/qltk/tracknumbers.py
-@@ -160,13 +160,6 @@ class TrackNumbers(Gtk.VBox):
- if song.get("tracknumber") == track:
- win.step()
- continue
-- if not song.valid():
-- win.hide()
-- dialog = OverwriteWarning(self, song)
-- resp = dialog.run()
-- win.show()
-- if resp != OverwriteWarning.RESPONSE_SAVE:
-- break
- song["tracknumber"] = track
- try:
- song.write()
diff --git a/makefu/5pkgs/custom/quodlibet/single-digit-discnumber.patch b/makefu/5pkgs/custom/quodlibet/single-digit-discnumber.patch
deleted file mode 100644
index 05778fde..00000000
--- a/makefu/5pkgs/custom/quodlibet/single-digit-discnumber.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/quodlibet/pattern/_pattern.py b/quodlibet/pattern/_pattern.py
-index fc056d07a..8fb559c6e 100644
---- a/quodlibet/pattern/_pattern.py
-+++ b/quodlibet/pattern/_pattern.py
-@@ -387,7 +387,7 @@ def _number(key, value):
- elif key == "discnumber":
- parts = value.split("/")
- try:
-- return "%02d" % int(parts[0])
-+ return "%d" % int(parts[0])
- except (TypeError, ValueError):
- return value
- else: