summaryrefslogtreecommitdiffstats
path: root/makefu/3modules/torrent.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/3modules/torrent.nix')
-rw-r--r--makefu/3modules/torrent.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/makefu/3modules/torrent.nix b/makefu/3modules/torrent.nix
new file mode 100644
index 00000000..9f1cf339
--- /dev/null
+++ b/makefu/3modules/torrent.nix
@@ -0,0 +1,13 @@
+{config, lib, pkgs, ... }:
+
+{
+ options.makefu.dl-dir = lib.mkOption {
+ type = lib.types.str;
+ description = "Default download directory";
+ default = "/media/cryptX/torrent";
+ };
+ options.makefu.torrent-secrets = lib.mkOption {
+ type = lib.types.str;
+ default = "/home/makefu/secrets/torrent";
+ };
+}