summaryrefslogtreecommitdiffstats
path: root/makefu/3modules/state.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/3modules/state.nix')
-rw-r--r--makefu/3modules/state.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/makefu/3modules/state.nix b/makefu/3modules/state.nix
new file mode 100644
index 00000000..461b9015
--- /dev/null
+++ b/makefu/3modules/state.nix
@@ -0,0 +1,9 @@
+{config, lib, pkgs, ... }:
+
+{
+ options.state = lib.mkOption {
+ type = lib.types.listOf lib.types.str;
+ description = "state which is currently scattered on the machine";
+ default = [];
+ };
+}