summaryrefslogtreecommitdiffstats
path: root/makefu/3modules/state.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/3modules/state.nix')
-rw-r--r--makefu/3modules/state.nix16
1 files changed, 0 insertions, 16 deletions
diff --git a/makefu/3modules/state.nix b/makefu/3modules/state.nix
deleted file mode 100644
index a87f438f..00000000
--- a/makefu/3modules/state.nix
+++ /dev/null
@@ -1,16 +0,0 @@
-{config, lib, pkgs, ... }:
-
-{
- options.state = lib.mkOption {
- type = lib.types.listOf lib.types.str;
- description = "state which is currently scattered on the machine";
- default = [];
- };
-
- config.system.activationScripts.state = lib.optionalString (config.state != []) ''
- cat << EOF
- This machine is burdened with state:
- ${lib.concatMapStringsSep "\n" (d: "* ${d}") config.state}
- EOF
- '';
-}