summaryrefslogtreecommitdiffstats
path: root/makefu/3modules/forward-journal.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/3modules/forward-journal.nix')
-rw-r--r--makefu/3modules/forward-journal.nix50
1 files changed, 0 insertions, 50 deletions
diff --git a/makefu/3modules/forward-journal.nix b/makefu/3modules/forward-journal.nix
deleted file mode 100644
index f501048b..00000000
--- a/makefu/3modules/forward-journal.nix
+++ /dev/null
@@ -1,50 +0,0 @@
-{ config, lib, pkgs, ... }:
-
-with import <stockholm/lib>;
-let
- cfg = config.makefu.forward-journal;
-
- out = {
- options.makefu.forward-journal = api;
- config = lib.mkIf cfg.enable imp;
- };
-
- api = {
- enable = mkEnableOption "forward journal via syslog";
- src = mkOption {
- type = types.str;
- description = "syslog host identifier";
- default = config.networking.hostName;
- };
- dst = mkOption {
- type = types.str;
- description = "syslog host identifier";
- default = "";
- };
- proto = mkOption {
- type = types.str;
- default = "udp";
- };
- port = mkOption {
- type = types.int;
- description = "destination port";
- default = 514;
- };
-
- };
-
- imp = {
- services.syslog-ng = {
- enable = true;
- extraConfig = ''
- template t_remote { template("<$PRI>$DATE ${cfg.src} $PROGRAM[$PID]: $MSG\n"); };
- source s_all { system(); internal(); };
- destination d_loghost { udp("${cfg.dst}" port(${toString cfg.port}) template(t_remote)); };
- log { source(s_all); destination(d_loghost); };
- '';
- };
- };
-
-in
-out
-