summaryrefslogtreecommitdiffstats
path: root/makefu/3modules/bump-distrowatch.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/3modules/bump-distrowatch.nix')
-rw-r--r--makefu/3modules/bump-distrowatch.nix31
1 files changed, 0 insertions, 31 deletions
diff --git a/makefu/3modules/bump-distrowatch.nix b/makefu/3modules/bump-distrowatch.nix
deleted file mode 100644
index f8ba18ce..00000000
--- a/makefu/3modules/bump-distrowatch.nix
+++ /dev/null
@@ -1,31 +0,0 @@
-{ config, lib, pkgs, ... }:
-
-let
- cfg = config.makefu.distrobump;
-
- imp = {
- systemd.services.distrobump = {
- after = [ "network-online.target" ];
- wantedBy = [ "multi-user.target" ];
- path = [ pkgs.curl ];
- restartIfChanged = false;
- startAt = "daily";
- serviceConfig = {
- PrivateTmp = true;
- Type = "oneshot";
- ExecStart = pkgs.writeDash "bump-distrowatch" ''
- set -euf
- UA='Mozilla/5.0 (X11; Linux x86_64; rv:63.0) Gecko/20100101 Firefox/63.0'
- curl -Lvc /tmp/cookie.jar -A "$UA" 'https://distrowatch.com/' >/dev/null
- sleep $(shuf -i 3-15 -n1).$(shuf -i 0-9 -n1)
- curl -Lvc /tmp/cookie.jar -A "$UA" -e 'https://distrowatch.com/' 'https://distrowatch.com/nixos?frphr' >/dev/null
- '';
- RandomizedDelaySec = 28800;
- };
- };
- };
-in
-{
- options.makefu.distrobump.enable = lib.mkEnableOption "distrobump";
- config = lib.mkIf cfg.enable imp;
-}