summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/wwan.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/2configs/wwan.nix')
-rw-r--r--makefu/2configs/wwan.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/makefu/2configs/wwan.nix b/makefu/2configs/wwan.nix
index fdf3e8df..1492213b 100644
--- a/makefu/2configs/wwan.nix
+++ b/makefu/2configs/wwan.nix
@@ -1,4 +1,5 @@
{ config, lib, pkgs, ... }:
+
let
mainUser = config.krebs.build.user;
in {
@@ -6,5 +7,21 @@ in {
wvdial
];
+ # configure for NETZCLUB
+ environment.wvdial.dialerDefaults = ''
+ Phone = *99***1#
+ Dial Command = ATDT
+ Modem = /dev/ttyACM0
+ Baud = 460800
+ Init1 = AT+CGDCONT=1,"IP","pinternet.interkom.de","",0,0
+ Init2 = ATZ
+ Init3 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
+ ISDN = 0
+ Modem Type = Analog Modem
+ Username = netzclub
+ Password = netzclub
+ Stupid Mode = 1
+ Idle Seconds = 0'';
+
users.extraUsers.${mainUser.name}.extraGroups = [ "dialout" ];
}