summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/storj/forward-port.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/2configs/storj/forward-port.nix')
-rw-r--r--makefu/2configs/storj/forward-port.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/makefu/2configs/storj/forward-port.nix b/makefu/2configs/storj/forward-port.nix
new file mode 100644
index 00000000..213f7747
--- /dev/null
+++ b/makefu/2configs/storj/forward-port.nix
@@ -0,0 +1,22 @@
+{
+ networking.firewall.allowedTCPPorts = [ 28967 ];
+ #networking.nat.forwardPorts = [
+ # { # storj
+ # destination = "10.243.0.89:28967";
+ # proto = "tcp";
+ # sourcePort = 28967;
+ # }
+ #];
+ services.nginx.appendConfig = ''
+ stream {
+ upstream storj {
+ server omo.r:28967;
+ }
+
+ server {
+ listen 28967;
+ proxy_pass storj;
+ }
+ }
+ '';
+}