summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/share/temp-share-samba.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/2configs/share/temp-share-samba.nix')
-rw-r--r--makefu/2configs/share/temp-share-samba.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/makefu/2configs/share/temp-share-samba.nix b/makefu/2configs/share/temp-share-samba.nix
new file mode 100644
index 00000000..0907c2db
--- /dev/null
+++ b/makefu/2configs/share/temp-share-samba.nix
@@ -0,0 +1,31 @@
+{config, ... }:{
+ networking.firewall.allowedUDPPorts = [ 137 138 ];
+ networking.firewall.allowedTCPPorts = [ 139 445 ];
+ users.users.smbguest = {
+ name = "smbguest";
+ uid = config.ids.uids.smbguest;
+ description = "smb guest user";
+ home = "/home/share";
+ createHome = true;
+ };
+ services.samba = {
+ enable = true;
+ shares = {
+ share-home = {
+ path = "/home/share/";
+ "read only" = "no";
+ browseable = "yes";
+ "guest ok" = "yes";
+ };
+ };
+ extraConfig = ''
+ guest account = smbguest
+ map to guest = bad user
+ # disable printing
+ load printers = no
+ printing = bsd
+ printcap name = /dev/null
+ disable spoolss = yes
+ '';
+ };
+}