summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/share/gum-client.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/2configs/share/gum-client.nix')
-rw-r--r--makefu/2configs/share/gum-client.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/makefu/2configs/share/gum-client.nix b/makefu/2configs/share/gum-client.nix
new file mode 100644
index 00000000..be9ab026
--- /dev/null
+++ b/makefu/2configs/share/gum-client.nix
@@ -0,0 +1,23 @@
+{ config, lib, pkgs, ... }:
+
+let
+ automount_opts =
+ [ "x-systemd.automount"
+ "noauto" "x-systemd.idle-timeout=600"
+ "x-systemd.device-timeout=5s"
+ "x-systemd.mount-timeout=5s"
+ ];
+ host = "nextgum"; #TODO
+in {
+ fileSystems."/media/download" = {
+ device = "//${host}/download";
+ fsType = "cifs";
+ options = automount_opts ++
+ [ "credentials=/var/src/secrets/download.smb"
+ "file_mode=0775"
+ "dir_mode=0775"
+ "uid=9001"
+ ];
+ };
+
+}