summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/share/anon-ftp.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/2configs/share/anon-ftp.nix')
-rw-r--r--makefu/2configs/share/anon-ftp.nix31
1 files changed, 0 insertions, 31 deletions
diff --git a/makefu/2configs/share/anon-ftp.nix b/makefu/2configs/share/anon-ftp.nix
deleted file mode 100644
index d2a535f9..00000000
--- a/makefu/2configs/share/anon-ftp.nix
+++ /dev/null
@@ -1,31 +0,0 @@
-{ config, lib, ... }:
-let
- ftpdir = "/data";
-in {
- networking.firewall = {
- allowedTCPPorts = [ 20 21 ];
- autoLoadConntrackHelpers = true;
- connectionTrackingModules = [ "ftp" ];
- extraCommands = ''
- iptables -A PREROUTING -t raw -p tcp --dport 21 -j CT --helper ftp
- '';
- };
- systemd.services.vsftpd.preStart = lib.mkForce ''
- mkdir -p -m755 ${ftpdir}/incoming
- chown root:root ${ftpdir}
- chown ftp ${ftpdir}/incoming
- '';
- services.vsftpd = {
- enable = true;
- extraConfig = ''
- ftpd_banner=Welcome to the krebs share, use the incoming dir for new and old leaks. Join freenode#krebs
- '';
- anonymousUser = true;
- anonymousUserNoPassword = true;
- anonymousUploadEnable = true;
- anonymousMkdirEnable = true;
- writeEnable = true;
- chrootlocalUser = true;
- anonymousUserHome = ftpdir;
- };
-}