summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/rtorrent.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/2configs/rtorrent.nix')
-rw-r--r--makefu/2configs/rtorrent.nix10
1 files changed, 8 insertions, 2 deletions
diff --git a/makefu/2configs/rtorrent.nix b/makefu/2configs/rtorrent.nix
index d024ded9..9e2990ca 100644
--- a/makefu/2configs/rtorrent.nix
+++ b/makefu/2configs/rtorrent.nix
@@ -2,11 +2,17 @@ _:
let
listenPort = 60123;
xml-port = 5000;
+ authfile = <torrent-secrets/authfile>;
in {
makefu.rtorrent = {
enable = true;
- web.enable = true;
- xmlrpc = "localhost:${toString xml-port}";
+ web = {
+ enable = true;
+ enableAuth = true;
+ inherit authfile;
+ };
+ rutorrent.enable = true;
+ enableXMLRPC = true;
logLevel = "debug";
inherit listenPort;
};